home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / x11-misc / engage-9999 / engage-9999.ebuild < prev    next >
Encoding:
Text File  |  2006-01-09  |  702 b   |  31 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/x11-misc/engage/engage-9999.ebuild,v 1.5 2005/04/10 21:02:56 vapier Exp $
  4.  
  5. ECVS_MODULE="misc/engage"
  6. EHACKAUTOGEN=yes
  7. inherit enlightenment
  8.  
  9. DESCRIPTION="nice bar thingy"
  10.  
  11. IUSE="xinerama"
  12.  
  13. DEPEND=">=x11-libs/esmart-0.9.0
  14.     >=media-libs/imlib2-1.2.0
  15.     >=media-libs/edje-0.5.0
  16.     >=x11-libs/ecore-0.9.9
  17.     >=x11-libs/evas-0.9.9
  18.     >=x11-libs/ewl-0.0.4
  19.     >=app-misc/examine-0.0.1.20050116"
  20.  
  21. src_compile() {
  22.     export MY_ECONF="$(use_enable xinerama)"
  23.     enlightenment_src_compile
  24. }
  25.  
  26. src_install() {
  27.     enlightenment_src_install
  28.     exeinto /usr/share/engage
  29.     doexe build_icon.sh
  30. }
  31.